Resolve Google play service issue in Samsung Galaxy Note 3

 

Resolve ‘Your device is not compatible with this version’ issue of Samsung Galaxy Note 3 while installing Google play service on Lollypop update

Google-Play-Services-Guide

It looks all the forums are flooded with this question. It usually happens after factory reset of a Samsung Galaxy Note 3 after Lollipop update. Same like to many other, it happned to me as well. It might be a Samsung bug as it seems to be reported only from Galaxy Note 3. I am sorry for blamming Google at the begining. 😀

The simplest solution is to download the Google play service APK from and external source and install it manually. To install it ..

  1. Download the Latest APK v9.2.56 from an external link.
  2. Enable “Unknown sources” from ( Setting -> Security -> Unknown sources ) your Note 3
  3. Copy the downloaded APK to your mobile storage.
  4. Open and Install.

Done !.

Please try this and let me know your comments. Thanks.

3 comments Add yours

Leave a Reply

Your email address will not be published. Required fields are marked *


*

Please wrap all source codes with [code][/code] tags.